This web site contains YouMail's Visual Voicemail for BlackBerry software Version 2.1.0 (6)

Important: There are several different versions of this software, please make sure you download and install the correct one


For BlackBerry devices with OS 6.0 or greater

For BlackBerry devices with OS 5.0

For BlackBerry devices with OS 4.7

For BlackBerry devices with OS 4.6.1

For BlackBerry devices with OS 4.5 or 4.6.0

Note that the YouMail BlackBerry software does not support BlackBerry devices with OS prior to 4.5.

Many older devices can be upgraded to OS 4.5 or later, check with your carrier or go to www.blackberry.com